Announcement

Collapse
No announcement yet.

Intel 2200bg and linux probs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intel 2200bg and linux probs

    Hey guys im new to the forums and this is my first post. That said please bear with me as I am also new to linux, but very eager to learn.

    Here are the issue that I am having:

    1. I initially could not get the intel pro wireless 2200 b/g adapter to work with linux. As of now i know of 3 ways to make it work. The first is a native linux driver sponsered by intel found at sourceforge, it is called ipw2200. I cannot get this to work because of problems with the makefile and my particular distro of linux (knoppix , noob central). ONe of the other ways is with a product by linuxant which is basically a driver wrapper which uses the windows drivers. Again i could not get this to work because the setup didnt realize the knoppix was debian based. The final way which i have been able to make work is usind ndiswrapper and the current windows drivers. This is apparently working fine , but i think there are some problems are this is not a native windows driver.

    2. I cant seem to find the existence of "monitor mode" and i have looked at some pretty good sources books etc (i would reccomend a book called Wardriving (drive detect defend) not sure of the author but its a great book. This book outlines ways to activate montor mode for orinoco and prism chipset based wifi cards. I dont believe the intel 2200 is either of these so my only option is to wait for a better driver to become available or get a easier to configure wifi card.

    3. Now here is my interesting question. Even though i cant get monitor or promiscous mode to work (not sure of the difference yet, only get confused as i read more some say monitor is pur listening and some others say the same about promiscous including the help in ethereal). I have been experementing wiht spoofing mac addresses. I know how to change a mac adress in linux (with ifconfig and iwconfig etc) but once i change the mac address i cant get the card to get and ip , either through dhcp or by manually setting the ip and gateway. However i can spoof a mac in windows with the same card (laptop is dual boot) and get it to bind with the ap using dhcp. DO you think that this problems is because the ndiswrapper way of doing things is not a native linux driver? BTW after changing the mac address in linux i cant get an ip even if there is not mac address filtering enabled on the AP.

    The 3rd question is the real question, that i would like some information about.
    BTW my setup is:
    dell 600m
    dual (triple boot) winxp, winxppro, knoppix
    intel 2ghz centrino
    intel 2200 bg wireless adapter
    768 mb ram
    60gb hd

    the AP is a netgear wireless 802.11B router dont remeber the model number but its the blue one not the newer silver one.

    Thanks in advance.

  • #2
    I can't claim to be familiar with your particular adapter, but I have spent a fair amount of time pounding on various 802.11g cards to make them work under teh loonix. Onwards...

    Originally posted by tizbad99
    1. I initially could not get the intel pro wireless 2200 b/g adapter to work with linux. As of now i know of 3 ways to make it work. The first is a native linux driver sponsered by intel found at sourceforge, it is called ipw2200. I cannot get this to work because of problems with the makefile and my particular distro of linux (knoppix , noob central).
    What makefile issues are you seeing? Exact errors would help.

    The final way which i have been able to make work is usind ndiswrapper and the current windows drivers. This is apparently working fine , but i think there are some problems are this is not a native windows driver.
    This is probably your best bet for now, assuming that the native Intel drivers can't be built. I'm running ndiswrapper for a Netgear WG311 in one of my boxes, and it works great. Of course, you won't be able to use the card for things like wardriving - generally, only ad-hoc and managed modes are supported under ndiswrapper. If you can live with this, it's your best option as long as the Intel drivers won't build.

    2. I cant seem to find the existence of "monitor mode" and i have looked at some pretty good sources books etc (i would reccomend a book called Wardriving (drive detect defend) not sure of the author but its a great book. This book outlines ways to activate montor mode for orinoco and prism chipset based wifi cards. I dont believe the intel 2200 is either of these so my only option is to wait for a better driver to become available or get a easier to configure wifi card.
    See above. You might also want to go over the ndiswrapper FAQ - a lot of the questions you're likely to have are going to be answered there.

    3. Now here is my interesting question. Even though i cant get monitor or promiscous mode to work (not sure of the difference yet, only get confused as i read more some say monitor is pur listening and some others say the same about promiscous including the help in ethereal).
    Monitor mode and promiscuous mode are two entirely different things. Monitor mode is radio-based - i.e., it's a way for the radio component of the card to detect other adapters/access points within range. Promiscuous mode is a component of the card's ethernet chipset (which means that wired ethernet cards will also support it), and provides a way for IP traffic not destined for that specific ethernet card to be captured.

    Comment


    • #3
      I cant remember the makefile issues exactly, but the following is what came up when i did a search on google. The kernel version is not the same and the dirs are not the same either, whats below is the problem that someone else experieced. ILl post the actual errors later when i can get to my box.

      "make -C /lib/modules/2.6.8.1-12mdk/build SUBDIRS=/home/paul/intel/ipw2200-0.18 MODVERDIR=/home/paul/intel/ipw2200-0.18 modules
      make[1]: Entering directory `/lib/modules/2.6.8.1-12mdk/build'
      make -C /lib/modules/2.6.8.1-12mdk/ SUBDIRS=/lib/modules/2.6.8.1-12mdk/build MODVERDIR=/lib/modules/2.6.8.1-12mdk/build modules
      make[2]: Entering directory `/lib/modules/2.6.8.1-12mdk'
      make[2]: *** No rule to make target `modules'. Stop.
      make[2]: Leaving directory `/lib/modules/2.6.8.1-12mdk'
      make[1]: *** [modules] Error 2
      make[1]: Leaving directory `/lib/modules/2.6.8.1-12mdk/build'
      make: *** [modules] Error 2"

      my issues are basically the same but not as many error lines, and i called the make file by simply saying "make" . But it definately says "no rule to make target" atleast once. and "stop" and "error" a bunch of times. My feeling is that the reason is because the makefile points to a shortcut thing called build which points to another directory which is supposed to have the kernel source in it.

      I think that my problem comes from the fact that when i boot knoppix i can choose the 2.6 kernel as opposed to the 2.4 but for knoppix 2.6 is an experimental kernel and i dont think that the install sets up the source and everything as it should properly in all the directories.

      BTW the makefile shows the same errors when i run in using the 2.4 kernel (just as an experiment i know the ipw dirver doesnt support 2.4 but i just wanted to see if the errors would be the same). SO i could be wrong about the reasoning, i think i should just install debian and be done with knoppix. But im a bit worried about wether or not the install is as user friendly and i will be able to setup lilo so that i can boot from windows as well. ALso another cause for worry is that dell laptops come with a number of extra partions (diagnostic and stuff) and i didnt want to run the risk of ruining the MBR or somthing since im such a noob.

      Thanks

      Comment


      • #4
        Originally posted by tizbad99
        I cant remember the makefile issues exactly, but the following is what came up when i did a search on google. The kernel version is not the same and the dirs are not the same either, whats below is the problem that someone else experieced. ILl post the actual errors later when i can get to my box.
        Yes, without your actual build errors there's not a lot that can be done to help with your specific issue.

        my issues are basically the same but not as many error lines, and i called the make file by simply saying "make" . But it definately says "no rule to make target" atleast once. and "stop" and "error" a bunch of times. My feeling is that the reason is because the makefile points to a shortcut thing called build which points to another directory which is supposed to have the kernel source in it.
        That's entirely possible, but it's only conjecture until the build errors can be seen.

        I think that my problem comes from the fact that when i boot knoppix i can choose the 2.6 kernel as opposed to the 2.4 but for knoppix 2.6 is an experimental kernel and i dont think that the install sets up the source and everything as it should properly in all the directories.
        Also possible, but have you checked the requirements listed on the ipw2200 project homepage? It's possible that you're not meeting all of them. Incidentally, I'm assuming that the driver tarball unpacks an INSTALL or README (or BUILDING, or something similar) file along with the source... Have you checked those? There may be configuration (automatic or otherwise) you need to perform before actually running `make'.

        i think i should just install debian and be done with knoppix.
        Either way, you're still going to end up with Linux. Installing another distribution may fix the problem; it also may not. Besides, if you never learn how to deal with the issues you're seeing now you won't have learned anything in the process.

        But im a bit worried about wether or not the install is as user friendly and i will be able to setup lilo so that i can boot from windows as well.
        Define 'user friendly'. I happen to find Slackware's entirely non-graphical installation process extremely user-firendly; Mandrake users would probably disagree with me. As for lilo, pretty much every distribution out there should install it (or grub, or equivalent other bootloader).

        ALso another cause for worry is that dell laptops come with a number of extra partions (diagnostic and stuff) and i didnt want to run the risk of ruining the MBR or somthing since im such a noob.
        Don't resize, move, or remove the recovery partitions and you should be OK. Now, let's keep this on track for the original question.

        Comment


        • #5
          sorry for the late reply i was out of the country for a bit. Thanks for the help so far.

          Here are the results of the makefile:

          root@beastbox:/home/tdizzle/Desktop/ip/ipw2200-0.19# make
          make -C /lib/modules/2.6.7/build SUBDIRS=/home/tdizzle/Desktop/ip/ipw2200-0.19 MODVERDIR=/home/tdizzle/Desktop/ip/ipw2200-0.19 modules
          make: *** /lib/modules/2.6.7/build: Not a directory. Stop.
          make: *** [modules] Error 2
          ----------------------------------------------------------------------------


          here is whats in the that directory:
          root@beastbox:/lib/modules/2.6.7# ls
          build misc modules.dep modules.isapnpmap modules.usbmap
          kernel modules.alias modules.ieee1394map modules.pcimap net
          madwifi modules.ccwmap modules.inputmap modules.symbols
          -----------------------------------------------------------------------------------

          the thing called build seems to be an undefined link to somthing , its blank when i try to emacs it.

          then if i replace that link with a foler called build this is what i get when i call the make:

          root@beastbox:/home/tdizzle/Desktop/ip/ipw2200-0.19# make
          make -C /lib/modules/2.6.7/build SUBDIRS=/home/tdizzle/Desktop/ip/ipw2200-0.19 MODVERDIR=/home/tdizzle/Desktop/ip/ipw2200-0.19 modules
          make[1]: Entering directory `/lib/modules/2.6.7/build'
          make[1]: *** No rule to make target `modules'. Stop.
          make[1]: Leaving directory `/lib/modules/2.6.7/build'
          make: *** [modules] Error 2
          -----------------------------------------------------------------------------------

          so im not really sure whats up

          Comment


          • #6
            Originally posted by tizbad99
            root@beastbox:/home/tdizzle/Desktop/ip/ipw2200-0.19# make
            make -C /lib/modules/2.6.7/build SUBDIRS=/home/tdizzle/Desktop/ip/ipw2200-0.19 MODVERDIR=/home/tdizzle/Desktop/ip/ipw2200-0.19 modules
            make: *** /lib/modules/2.6.7/build: Not a directory. Stop.
            make: *** [modules] Error 2
            ----------------------------------------------------------------------------
            Just as it reports. There appears to be a file "/lib/modules/2.6.7/build" but the file does not appear to be a directory.
            The most likely reason for this, is the file is a "dangling symlink" (The thing that it was pointing to is or never was where it is pointing to right now.)

            To see what the symlink points to do this:
            # ls -ld /lib/modules/2.6.7/build
            You should see something like this:
            lrwxrwxrwx 1 root root 21 Jan 21 01:48 build -> /usr/src/linux-2.6.7

            In this case, there is a symlink called "build" which is a "shortcut" or "alias" to another location on the filesystem.

            Best guess, there is no file/dir located at /usr/src/linux-2.6.7

            here is whats in the that directory:
            root@beastbox:/lib/modules/2.6.7# ls
            build misc modules.dep modules.isapnpmap modules.usbmap
            kernel modules.alias modules.ieee1394map modules.pcimap net
            madwifi modules.ccwmap modules.inputmap modules.symbols
            -----------------------------------------------------------------------------------

            the thing called build seems to be an undefined link to somthing , its blank when i try to emacs it.

            then if i replace that link with a foler called build this is what i get when i call the make:

            root@beastbox:/home/tdizzle/Desktop/ip/ipw2200-0.19# make
            make -C /lib/modules/2.6.7/build SUBDIRS=/home/tdizzle/Desktop/ip/ipw2200-0.19 MODVERDIR=/home/tdizzle/Desktop/ip/ipw2200-0.19 modules
            make[1]: Entering directory `/lib/modules/2.6.7/build'
            make[1]: *** No rule to make target `modules'. Stop.
            make[1]: Leaving directory `/lib/modules/2.6.7/build'
            make: *** [modules] Error 2
            -----------------------------------------------------------------------------------

            so im not really sure whats up
            I am going to assume that you did not build your own kernel, but instead are using a kernel that came with your OS from the install CD or an upgrade.

            What you need is the kernel source tree for the same kernel you are presently running, and then you need to have that installed in a place that is available from the "build"symlink path. (If your OS/Distro is worth anything, installing the matching kernel source tree should automagically fix the dangling symlink problem in your /lib/modules-2.6.7/build symlink.)

            For many RedHat and Debian, these are packages that include the name "src" as part of them. These are copies of source code to match the binary package of the same name.

            So, if you are using say "linux kernel 2.6.7" and the package name is "linux-2.6.7-RN-kernel" see if you can find a package "linux-2.6.7-RN-kernel-src" Names of packages may be different, but for your kernel package, there should be a package with "src" or "source" as part of the name and maybe a third with the name "header".

            Try to install your kernel's packaged source tree. See if the symlink mentioned above works.

            If so, then try to build your package again.

            If you do not have a source tree that matches that of your current kernel, and cannot find one, you can *try* using a stock kernel of the same version from ftp.kernel.org but it is more likely that you might need to build your own kernel before you build the project that started this thread. (This assumes you are unable to find a packaged source tree that matches your presently running kernel.)

            If all tries fail, and you decide to build a kernel, realize it is an iterative process where each try gets you closer to an "optimized" kernel. Many people take 10 to 20 hours to build their first working kernels.

            [Optimized kernels with best choices in options for your specializations can take weeks or longer is you are a perfectionist. :-) ]

            [More content added:]
            Looking at the link that skroo provided you, I can see some things that will help you as linked directly from skroo's URL ipw2200 project homepage:
            http://ipw2200.sourceforge.net/INSTALL

            You also need a kernel that supports some kernel features/options that may not be part of the standard kernels offered by Linux Distros. (See the Section "CONFIGURING THE KERNEL" in the "INSTALL" URL above.)

            It is looking more and more like you will be forced to build your own kernel to make this work.
            Last edited by TheCotMan; January 24, 2005, 22:21.

            Comment


            • #7
              OK well i had a good thing going and managed to screw it up.

              Earlier i could atleast use ndiswrapper to use the intel pro wireless 2200 , and it used to work just fine.

              Now i cant cant even get that to work.
              Earlier all i would do is:
              #ndiswrapper -i w22n51.inf (the windows driver)
              #modprobe ndiswrapper
              #ifconfig wlan0 up

              and then i would use dhcp to get an ip.

              NOw for some reason i cant even get that to work, now when i do:
              # ifconfig wlan0 up
              wlan0: ERROR while getting interface flags: No such device
              ------------------------------------------------
              and ndiswrapper has the driver loaded.:

              # ndiswrapper -l
              Installed ndis drivers:
              w22n51

              ---------------------------------------------------
              and ndiswrapper s listed when i do lsmod.



              why does it not work now, and it used to work earlier???? i have even reinstalled knoppix a bunch of times with different versions and i still cant get it to work.

              any ideas? the hardware works fine when in windows.

              Comment


              • #8
                Originally posted by tizbad99
                OK well i had a good thing going and managed to screw it up.

                Earlier i could atleast use ndiswrapper to use the intel pro wireless 2200 , and it used to work just fine.

                Now i cant cant even get that to work.
                Earlier all i would do is:
                #ndiswrapper -i w22n51.inf (the windows driver)
                #modprobe ndiswrapper
                #ifconfig wlan0 up

                and then i would use dhcp to get an ip.

                NOw for some reason i cant even get that to work, now when i do:
                # ifconfig wlan0 up
                wlan0: ERROR while getting interface flags: No such device
                ------------------------------------------------
                and ndiswrapper has the driver loaded.:

                # ndiswrapper -l
                Installed ndis drivers:
                w22n51

                ---------------------------------------------------
                and ndiswrapper s listed when i do lsmod.



                why does it not work now, and it used to work earlier???? i have even reinstalled knoppix a bunch of times with different versions and i still cant get it to work.

                any ideas? the hardware works fine when in windows.
                5 things:
                1) What changed between the time it was working and the time it was not?
                2) Reboot (start with fresh boot) and see if it works. If this "fixes" it then, when it happens again, you can examine the log files to understand what was wrong. (There could be many reasons for it not working now. See if a reboot "fixes" things. If it does, you have somemthing to use in troubleshooting the problem (base-case state where tings work vs. new state where things are not working.)
                3) Look at your log files. dmesg is your friend. "tail -f /var/log/logfilewithsystemmessagesfromkernel" is your friend. Look for where the ndis driver is loading and see if there is mention of the new network interface.
                4) I do not use the ndis driver collection (I buy Hardware in Linux HCL) but "wifi0" seems like an uncommon interface name. (Maybe it is common with 2.6.x and ndis drivers.) See if you have an "eth" interface for your wifi card. On Cisco AiroNet cards, a "raw" interface "wifi0" is created, but so is "eth1" and they are mappings to the same interface with different API. When I use dhclient, I tell to use eth1 not wifi0.
                5) test out a tool called "iwconfig" which can be used to associate your wireless NIC with an Axccess Point. It will also display a list of interfaces with wireless extensions. See what is reported by:
                # iwconfig
                and
                # ifconfig -a

                Try the above. If it works, then say what worked so others finding this thread with google will be able to use your learning experience. If it does not, then provide the log information from the kernel around the time that your ndis modules are loaded. Also, report the results of the iwconfig and ifconfig -a listed above.
                Last edited by TheCotMan; January 26, 2005, 20:25.

                Comment


                • #9
                  ok so i tried the stuff you said. The rebooting thing i had tried many times including trying different kernel sources for boot.

                  I also tried iwconfig and ifconfig -a to see what was listed

                  #iwconfig
                  lo no wireless extensions.

                  eth0 no wireless extensions.

                  sit0 no wireless extensions.
                  --------------------------------------------
                  #ifconifg -a
                  eth0 Link encap:Ethernet HWaddr 00:0F:1F:BA:38:A9
                  inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
                  inet6 addr: fe80::20f:1fff:feba:38a9/64 Scope:Link
                  UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
                  RX packets:13275 errors:0 dropped:0 overruns:0 frame:0
                  TX packets:9296 errors:0 dropped:0 overruns:0 carrier:0
                  collisions:0 txqueuelen:1000
                  RX bytes:19033279 (18.1 MiB) TX bytes:809736 (790.7 KiB)
                  Interrupt:11

                  lo Link encap:Local Loopback
                  inet addr:127.0.0.1 Mask:255.0.0.0
                  inet6 addr: ::1/128 Scope:Host
                  UP LOOPBACK RUNNING MTU:16436 Metric:1
                  RX packets:10 errors:0 dropped:0 overruns:0 frame:0
                  TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
                  collisions:0 txqueuelen:0
                  RX bytes:500 (500.0 b) TX bytes:500 (500.0 b)

                  sit0 Link encap:IPv6-in-IPv4
                  NOARP MTU:1480 Metric:1
                  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
                  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
                  collisions:0 txqueuelen:0
                  RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
                  ----------------------------------------------------------
                  so niether list wlan0 which is what it used to be called when it worked.

                  then i tried to look at dmesg.

                  this is the relevant part:
                  ndiswrapper version 0.8 loaded
                  ndiswrapper adding w22n51.sys
                  ndiswrapper: error log: C000138D, length: 0 (dd1f4178)
                  ndiswrapper: Windows driver couldn't initialize the device
                  w22n51.sys: probe of 0000:02:03.0 failed with error -22
                  ------------------------------------------------------------
                  so thats what that says,

                  Comment


                  • #10
                    Originally posted by tizbad99
                    ok so i tried the stuff you said. The rebooting thing i had tried many times including trying different kernel sources for boot.
                    [chop]
                    so niether list wlan0 which is what it used to be called when it worked.
                    Assuming that any other network cards listed by "ifconfig -a" are not the wireless card, iwconfig shows the present interfaces are not recognized as wireless, and it looks like ifconfig's listing of interfaces does not show a wireless interface.

                    then i tried to look at dmesg.

                    this is the relevant part:
                    ndiswrapper version 0.8 loaded
                    ndiswrapper adding w22n51.sys
                    ndiswrapper: error log: C000138D, length: 0 (dd1f4178)
                    ndiswrapper: Windows driver couldn't initialize the device
                    w22n51.sys: probe of 0000:02:03.0 failed with error -22
                    ------------------------------------------------------------
                    Excellent. So, this log message tells you what you know from the above ifconfig and iwconfig told you and what you suspected.

                    Now you have three choices IMO: (maybe more)
                    1) Use google and search on these error messages to see if others have encountered this problem
                    2) Examine your docs for ndis driver to see if this is described
                    3) Look through the source code for where this message is being reported, and look for what kind of detection or check is failing.

                    google: ndiswrapper C000138D is my first choice. There is no reason for me to invest time to solve a problem that has been solved by others. When docs and google fails, then I start looking through code and for apps, running gdb or strace on the app (more difficult with kernel drivers and modules) to find where it fails.

                    In this case, the first link reported from google is another forum where advice was offered about firmware not loading:
                    http://www.linuxquestions.org/questi...hreadid=277990

                    This would be the next lead to follow. If this fails, see what other leads are produced by google on this. If none of them pan out, then try either docs (if you skipped them before) and then try looking for where the error is generated from source to find out what was failing.

                    Comment


                    • #11
                      Install Windows, problem solved
                      45 5F E1 04 22 CA 29 C4 93 3F 95 05 2B 79 2A B0
                      45 5F E1 04 22 CA 29 C4 93 3F 95 05 2B 79 2A B1
                      [ redacted ]

                      Comment


                      • #12
                        Originally posted by bascule
                        Install Windows, problem solved
                        When people say things like "It works so much better in windows" I have no problem telling them to install windows if that is what they want.

                        I still believe that no common Linux distro is ready as the Operating System of Home Computers on average computer users' desktops.
                        (Not writing about consumer electronics here.)

                        [added content]

                        Also, if people want Linux to work well, they should use hardware supported directly by Linux drivers. Using Windows Drivers/firmware loading with things like ndiswrapper adds more work to the home user, relies upon an API for drivers controlled by a 3rd party, and adds one more link to the chain in things that can break or need work for each kernel upgrade.

                        Don't get me wrong; ndiswrapper is good to have around, but also decreases demand for true Linux support from hardware makers and is more of a crutch than a tool.
                        Last edited by TheCotMan; January 27, 2005, 13:34.

                        Comment


                        • #13
                          ok guys i finally got ndiswrapper to work again.

                          here is the deal:

                          when ndiswrapper shows errors in dmesg which say somthing like "windows drivers couldnt load the device" and then it cites an error code 22.

                          I looked it up in the ndiswrapper FAQ and it says the following, if the error code is present then it means that there is an irq problem. It recommends looking to see what is using what interrupts and stuff like that and then to free it up. ALso it mentions check your bios and acpi settings to see how irq are assigned.


                          SO in my case i had to change the hardware detection at the beggining of boot to see that the irq are assigned properly. Im sorry that i am not bieng more specific, i dont know enough yet and dont want to mislead someone.

                          thanks for all your help guys.

                          Comment


                          • #14
                            Originally posted by tizbad99
                            ok guys i finally got ndiswrapper to work again.

                            here is the deal:
                            It is very cool that you included a follow-up statement of how you were able to get it working. Other people finding this thread with google will then be able to use your work as a resource.

                            Comment


                            • #15
                              Originally posted by tizbad99
                              ok guys i finally got ndiswrapper to work again.
                              Why arent you using the Intel IPW2200 Linux drivers? You can get them from sourceforge.net

                              Comment

                              Working...
                              X