Announcement

Collapse
No announcement yet.

Right, thats it! Ive had enough!!!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TheCotMan
    replied
    Originally posted by TheCotMan
    Here is a crapload of content
    Originally posted by rules
    ...
    3. Graphics and Signatures
    ... If your signature is longer than your average post, its too long.
    ...
    Does this mean my sig can be 6 MB? ]:>
    Muwhahahahahahahaah!

    Leave a comment:


  • TheCotMan
    replied
    Originally posted by FunkyChicken
    Which_one_do_i_need?

    Theres soooo many there, how am i meant to tel which one is for red hat/fedora core?
    Fedora is described here on thier download link (instead of the "normal" files link.):
    http://gaim.sourceforge.net/downloads.php (I get my files from their "files" section and never really looked at the rpm-- I just assumed RH rpm would b there with the rest of the files.)

    it suggests you go here for latest gaim for Fedora core and latest gaim rpm:
    http://fedora.redhat.com/download/mirrors.html


    Here is a crapload of content to explain the files on that first URL if you want to learn what the names mean:
    ---
    I am a Debian Linux guy, but here are some informed guesses:
    These were built on/for "mandrake" systems: 10.0, 9.1 and 9.2:
    (Notice the "mdk" in the name followed by target Mandrake system version numbers)

    gaim-1.1.2-0mdk10.0.i586.rpm 3734468 i386 .rpm
    gaim-1.1.2-0mdk9.1.i586.rpm 3693185 i386 .rpm
    gaim-1.1.2-0mdk9.2.i586.rpm 3704466 i386 .rpm

    This is a generic src rpm so youu can build it ("it" probably being an rpm with a "spec" file or without the specfile and not as an rpm at all) from source:
    (This is probably the easiest to use other than a package from redhat.)
    gaim-1.1.2-0.src.rpm 7640065 Platform-Independent Source .rpm

    Windows items... Ignore:
    gaim-1.1.2-debug.exe 5437143 i386 .exe (32-bit Windows)
    gaim-1.1.2.exe 6443984 i386 .exe (32-bit Windows)
    gaim-1.1.2-no-gtk.exe 3126181 i386 .exe (32-bit Windows)

    bz compressed, non-packaged source trees in tarballs
    gaim-1.1.2.tar.bz2 5178791 Platform-Independent .bz2
    gpg sig for the above file to help verify the creator of this sig is the one who should be releasing it. You can check this sig file with gpg to help add more checking to the file you downloaded as being from the actual maintainers.
    (not perfect security, as you must trust the signer is who they say they are and nobody has the official signer passphrase, etc.)
    gaim-1.1.2.tar.bz2.asc 196 Platform-Independent Other

    Same as bz2 compressed files, but instead tarballs compressed with gzip instead:
    gaim-1.1.2.tar.gz 7642560 Platform-Independent .gz
    gpg sig for the above file to help verify the creator of this sig is the one who should be releasing it. You can check this sig file with gpg to help add more checking to the file you downloaded as being from the actual maintainers.
    (not perfect security, as you must trust the signer is who they say they are and nobody has the official signer passphrase, etc.)
    gaim-1.1.2.tar.gz.asc

    Same as above "mdk" files, but these are "Developmental" which mean they may have extra debugging info and could be slower OR these contain header files used by other projects to build items against the same version rpm above. (Some projects include debug versions in devepmental packages, some do not. "dev" or "developmental packages are usually not needed unless you are building stuff to go with the dev project tree. (Mandrake)
    gaim-devel-1.1.2-0mdk10.0.i586.rpm 110889 i386 .rpm
    gaim-devel-1.1.2-0mdk9.1.i586.rpm 110686 i386 .rpm
    gaim-devel-1.1.2-0mdk9.2.i586.rpm 110877 i386 .rpm

    "Secure Internet Live Conferencing" plugin for gaim: (mandrake)
    gaim-silc-1.1.2-0mdk10.0.i586.rpm 52834 i386 .rpm
    gaim-silc-1.1.2-0mdk9.1.i586.rpm 50554 i386 .rpm
    gaim-silc-1.1.2-0mdk9.2.i586.rpm 51164 i386 .rpm

    Tcl scripting support for Gaim (Mandrake)
    gaim-tcl-1.1.2-0mdk10.0.i586.rpm 18626 i386 .rpm
    gaim-tcl-1.1.2-0mdk9.1.i586.rpm 18198 i386 .rpm
    gaim-tcl-1.1.2-0mdk9.2.i586.rpm
    Last edited by TheCotMan; January 21, 2005, 03:52.

    Leave a comment:


  • FunkyChicken
    replied
    Which_one_do_i_need?

    Theres soooo many there, how am i meant to tel which one is for red hat/fedora core?

    Leave a comment:


  • TheCotMan
    replied
    Originally posted by FunkyChicken
    The program i am using for instant messaging is gaim. Every now and again it will crash.
    (Skipping the Q that has been addressed.)
    I find the best results for gaim come when I use the latest stable release from sourceforge. If you are using a packaged version of gaim that comes with RedHat, it is probably a bit old.
    Gaim is up to 1.1.1 as of the writing of this post [Actually gaim v 1.1.2 was released today, Jan 20, 2005]
    And if you are using RedHat, they have rpm you can download too.
    Last edited by TheCotMan; January 21, 2005, 00:33. Reason: Update link info on new version release same day as this post

    Leave a comment:


  • Voltage Spike
    replied
    Originally posted by FunkyChicken
    Is there a linux untility like windows Task Manager (Ctrl+Alt+Del)? Does it allow termination of running software?
    If you are looking into a graphical tool, then search for variants on the `top` utility. The first to spring to mind is the very nice-looking and functional `gtop`.

    There is also a utility called `xkill` for killing graphical applications (such as gaim). When you run it, the cursor will change its appearance and the next window you click will be terminated.

    Leave a comment:


  • FunkyChicken
    replied
    Thanks for all of the help guys ( + gurls)

    The program i am using for instant messaging is gaim. Every now and again it will crash.

    Is there a linux untility like windows Task Manager (Ctrl+Alt+Del)? Does it allow termination of running software?

    Cheers again people

    Leave a comment:


  • TheCotMan
    replied
    Originally posted by FunkyChicken
    i went and installed Fedora. It seems much much easier to use, and looks better aswell
    RedHat is easier to install, and get started, but the initial ease of use comes from leveraging people's learning of how to use an OS by memorization (the MS Way) instead of learning how to use many small tools to accomplish very complex tasks (the *NIX way.)
    Memorization empowers HR since simple animals can be trained to memorize things.
    Use of tools empower the user to make them more skilled and better able to complete tasks.

    The dns problem is fixed now (Mandrake must have been causing the problems) im gonna try to use this as my first linux OS, then hopefully i will move onto things like slackware and hopefully freeBSD.
    Good hacker approach. Don't settle for what people say the like. Try everything. Experience it for yourself. Choose what is best for you and learn it all.

    The learning curve for linux initially seems very steep
    Windows makes common user tasks easy, but at the cost of difficulty in complex tasks.
    *NIX makes simple tasks initially time consuming, but eventually effective, and many difficult tasks possible.

    Thanks very much for your help guys
    It was a group effort. :-)

    How do i go up a directory? cd..???
    If you are at a shell:
    $ cd ..
    or
    $ cd ../
    Should move you back up one dir.

    MSDOS/Windows uses "\" as the directory separation char while most *NIX use "/" as the directory separation char.
    So, you can use absolute paths with cd ans start with a leading "/"
    $ cd /home
    relative paths (relative to your present location in the filesystem)
    $ cd ../somedirectory
    back to your home directory according to /etc/passwd by specifying no args:
    $ cd

    Enjoy your new Linux system. Again, join a Linux User Group.

    Leave a comment:


  • FunkyChicken
    replied
    i went and installed Fedora. It seems much much easier to use, and looks better aswell (each have our own opinions)
    The dns problem is fixed now (Mandrake must have been causing the problems) im gonna try to use this as my first linux OS, then hopefully i will move onto things like slackware and hopefully freeBSD.

    The learning curve for linux initially seems very steep, especially in the CLI, i cant for the love of god figure out how to go up a directory (usually cd.. in windows)

    Thanks very much for your help guys, its been a great day (100% linux day)

    All i can say is that im really looking forward to experiencing linux as what i have seen so far is much better then windows (each have our own opinions).

    Its a shame linux is not more widely used and accepted as a operating system for the home user.

    Cheers guys

    P.s. How do i go up a directory? cd..???

    Leave a comment:


  • TheCotMan
    replied
    Originally posted by skroo
    Linux in a Nutshell is highly-recommended.
    I'll second that. Good book for people with some technical experience.

    Leave a comment:


  • skroo
    replied
    Originally posted by FunkyChicken
    matt is not in the sudoers file. This incident will be reported.
    `su', not `sudo' (for now). Example:

    skroo@seizure:~$ su
    Password: <enter root password here>
    root@seizure:/home/skroo#

    No sudoers config needed. Simply `exit' once you've made your changes and you'll be dropped back to whatever shell you were in before doing `su'.

    ive just gone out and bout a book called linux for dummies, it comes with fedora so i was thinking if i installed this it would be easier to follow as the distro would be the same as in the book
    One caveat: if you do that, you're only going to know that distro (in this case, Fedora, which is basically RedHat). And as most people will tell you, there are two ways of doing things in the Linux world: the Linux way and the RedHat way. Don't limit yourself to only knowing that one particular distro. Again, Linux in a Nutshell is highly-recommended.

    Leave a comment:


  • TheCotMan
    replied
    Originally posted by FunkyChicken
    arggghhhh!!!!
    Code:
    [matt@Federal matt]$ sudo [-u matt]
    matt is not in the sudoers file.  This incident will be reported.
    [matt@Federal matt]$
    What you see in the man page tells you "[ -u matt]" is a collection of optional args. You do not use the "[" and "]" in your command.

    Also, by deafult, sudo tries to do something as root.

    Next, you can add the name of a command to the end of sudo to be done as root.

    $ sudo xedit /path/to/a/file/toedit/as/root

    Before you go this path, try the above suggestions on configuring your NAT/Router to offer the ISP's DNS and/or try setting your machine to use a static IP address with static DNS IP addresses included in the config.

    And yes, using a book is a good idea, but man pages are your friend. Also, join a local linux user group.. they are great sources of information and hands-on aid.
    Last edited by TheCotMan; January 19, 2005, 12:28.

    Leave a comment:


  • FunkyChicken
    replied
    arggghhhh!!!!
    Code:
    [matt@Federal matt]$ sudo [-u matt]
    matt is not in the sudoers file.  This incident will be reported.
    [matt@Federal matt]$
    ive just gone out and bout a book called linux for dummies, it comes with fedora so i was thinking if i installed this it would be easier to follow as the distro would be the same as in the book

    Leave a comment:


  • TheCotMan
    replied
    Originally posted by FunkyChicken
    contents of resolv.conf

    Code:
    nameserver 127.0.0.1
    nameserver 192.168.1.1
    Yes. This is the file where your DNS IP Addresses are stored.

    [BAD ADVICE]
    You could always edit this file as root, set the IP addresses of your DNS that work (manually enter them) save the file, and then use "chattr" to set the immutable flag on /etc/resolve.conf so that the file cant be edited or altered or deleted unless chattr is used to remove the immutable flag.
    [/BAD ADVICE]


    i thought as i was the only user it means i am the administartor
    With most *NIX systems, it is best to be a normal user unless you have admin-things to do. When you have admin things to do, then you either "su" to root or you use "sudo" to complete a specific task.

    Some *NIX distros (Like Lindows) make the default user "root" but that is a bad practice.

    *NIX can be unforgiving. You may have cases where you are not asked, "Are you sure you want to do this?" , "Are you really sure you want to do this?" , "Can you rovide a note from your mommy that you really want to do this?" ... In many cases, *NIX systems are set up to just do what you tell them...no questions asked.

    examples:
    DO NOT DO THIS:
    # cat /dev/zero > /dev/hda
    (Zeros out your primary master IDE/ATA/EIDE hard disk)

    DO NOT DO THIS:
    # rm -rf /
    (tries to delete all files on the system)

    DO NOT DO THIS:
    # kill -9 -0
    (tries to kill all processes owned by root, though "-0" option may not be available on all kill apps.)

    Leave a comment:


  • FunkyChicken
    replied
    contents of resolv.conf

    Code:
    nameserver 127.0.0.1
    nameserver 192.168.1.1
    i thought as i was the only user it means i am the administartor

    Leave a comment:


  • TheCotMan
    replied
    Originally posted by FunkyChicken
    I can fix the DNS problem by going to "Configure your Computer" then manually entering my dns server ips, (got them from status page in my router config)
    Originally posted by skroo
    avoid using nonstandard stuff like graphical configuration utilities.
    I agree with that. There is a problem with this in the RedHat land (not sure about others.) If you decide to depart from the GUI system config tools, you should no go back to them while you manually edit config files, because there is risk that the nexttime the GUI config tools are run, for you to lose your custom settings.

    Using a text-teditor is how I do things, and it helps me to understand the services and their configuration in greater detail. This is (IMO) the direction a hacker would likely take to familiarize themself with a system.

    Originally posted by funkychicken
    194.72.9.38
    194.74.65.68

    everytime i reboot the machine the get set to

    Primary: 127.0.0.1
    Secondary: 192.168.1.1
    Yes. This is what I was writing about before. First, we see that since it works with these DNS IP addresses entered on the Linux box manually, we have a good indication that it is not a filtering problem. (This narrow the scope of our search.)

    Next, every reboot, your dhcp client likely runs and modifies the contents of /etc/resolv.conf (this is also the file that is being modified when you use that GUI tool to manually enter in your DNS IP addresses.)
    What to look at next:
    1) Is the DHCP server on your NAT/DSL Router configured to offer addresses for your DNS as 194.72.9.38 and 194.74.65.68 or is it configured to not specify any DNS? Can you set your DSL Router/NAT box to send client the 194.72.9.38 and 194.74.65.68 IP addresses for DNS? If so, try this.

    2) Your dhcp client may be configured to ignore dns offered from theserver too, and instead use something provided during install/config or a default.

    Item 1 or 2 are the likely problems you want to tackle.

    Originally posted by funkychicken
    here is the response i get from the dig command ( i done this after i change them to proper dns ips)

    [CHOP]
    The code results show me that 192.168.1.1 is acting as a DNS for you and should be a valid entry on your local machine. However, 127.0.0.1 is probably not valid if you dont have a local DNS Service running in Linux or it is misconfigured/not working.

    The other two DNS are probably your ISP's DNS.

    Originally posted by funkychicken
    My TCP/IP protocol is set up to be DHCP, does this mean that the dns server is getting set by my router each time i reboot??
    Yes. Your /etc/resolv.conf is being overwritten with new DNS info every time your get a new DHCP lease/assignment.


    Another solution:
    Tell your NAT/DSL Router to allow for assigning a static IP address to your Linux box based on its MAC Address, or see if you can allocate static IP addresses for machine on your network and have that work with your NAT/DSL Router. Then, you can switch your Linux box from using DHCP for assigned address to using a static assignment of an IP address and DNS that will not change on every reboot.

    Leave a comment:

Working...
X