No announcement yet.

Orinoco not working on my Thinkpad

  • Filter
  • Time
  • Show
Clear All
new posts

  • Orinoco not working on my Thinkpad

    I've got three Orinoco silver cards. I've tried SimplyMepis and Suse, as well as multiple kernels, and patched and unpatched Orinoco drivers.

    When I insert my orinoco silver card the modules are loaded correctly and I can connect to an access point, however if I try to issue an iwconfig command a second time, such as this:

    #iwconfig eth1 essid ANY mode managed

    then I get this:

    Error for wireless request "Set Mode" (8B06) :
    SET failed on device eth1 ; Device or resource busy.

    and then when I look at the status by issuing an iwconfig it shows this:

    eth1 IEEE 802.11-DS Nickname:"HERMES I"
    RTS thr:off
    Encryption key:off

    which is really weird.

    Also, I can see messages like this in my /var/log/messages:

    Jul 24 14:03:00 XX kernel: hermes @ 00010100: Card removed while issuing command 0x0011.
    Jul 24 14:03:01 XX kernel: hermes @ 00010100: Card removed while issuing command 0x0002.
    Jul 24 14:03:01 XX kernel: eth1: Unable to disable port while reconfiguring card
    Jul 24 14:03:01 XX kernel: eth1: Resetting instead...

    I also see these messages in /var/log/syslog:

    Jul 24 14:05:11 XX cardmgr[2451]: executing: './network stop eth1'
    Jul 24 14:05:11 XX cardmgr[2451]: + eth1: error fetching interface information: Device not found
    Jul 24 14:05:11 XX cardmgr[2451]: executing: 'modprobe -r orinoco_cs'

    I love my Orinoco cards and my cantennas. I must get this working. Has anyone seen this before or have any ideas? I'm wondering if it's something funky with my Thinkpad because I've used these cards with my old (defunct) Dell for years.


  • #2
    Originally posted by Jizzle
    I love my Orinoco cards and my cantennas. I must get this working. Has anyone seen this before or have any ideas? I'm wondering if it's something funky with my Thinkpad because I've used these cards with my old (defunct) Dell for years.
    Okay... It's showing the wireless card as eth1. This suggests to me (based on the information you've given so far) that there's a wired NIC in there as well, and (possibly) that for some reason the card is being properly detected but not fully installed as a wireless device. I ran into something similar years ago and am stretching to remember what the fix was.

    What kernel are you using, and what modules are loaded? Have you tried *not* issuing `mode managed' when doing the iwconfig? Some cards are picky about accepting multiple settings on one commandline; have you tried bringing it up, setting the ESSID, etc. separately? What happens if you down the wired NIC before inserting the Orinoco?


    • #3
      I've tried kernels ranging from 2.6.9 to (more or less). I have a built-in wired and a built-in wireless card. The orinoco usually shows up as eth2. In the example above I must have unloaded the modules for mt built-in wireless. The internal wired is usually "down" but still exists as eth0.

      I have also tried issuing the iwconfig commands separately, but stacking them up like that has always worked fine in the past.

      Keep in mind that the card will often associate with an AP fine. It's when I try to change the ESSID that I get the problem.


      • #4
        Does anyone here understand mtrr? I'm wondering if this message in my /var/log/messages could be related:

        kernel: mtrr: 0xe0000000,0x4000000 overlaps existing 0xe0000000,0x2000000

        can FYI
        # cat /proc/mtrr
        reg00: base=0x00000000 ( 0MB), size=1024MB: write-back, count=1
        reg01: base=0x3ff80000 (1023MB), size= 512KB: uncachable, count=1
        reg02: base=0xe0000000 (3584MB), size= 32MB: write-combining, count=1

        #lspci -v (reduced output)
        0000:01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] (prog-if 00 [VGA])
        Subsystem: IBM: Unknown device 0550
        Flags: bus master, fast Back2Back, 66MHz, medium devsel, latency 255, IRQ 11
        Memory at e0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 3000 [size=256]
        Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2

        I'm wondering if there's a problem with memory access for the video overlapping the PCMCIA area. I'm grasping at straws and don't really know what I'm talking about.



        • #5
          noit sure if this is related but heres my problem for SuSE

          Internal Nic and Senao Ext2 Wifi PCMCIA

          The only way i can get to wifi card to work is to follow these steps.

          Go into YaST (SuSE only)
          Then network connections
          Delete all of the connections
          Shutdown Laptop
          Eject PCMCIA
          Go into YaST
          Set-up eth0 (internal Nic) as basic settings (DHCP)
          insert PCMCIA wifi card
          go back into yast and delete eth0 settings
          now add eth1 settings for Wifi, make sure ssid is set for any

          hopefully that should work

          the error commands that you seem to be getting are very very similar to the ones i get, this is the only way i know how to fix the problem, try it for yourself, it may work.

          Initially i thought it was because the pcmcia card is not getting enough power, but then later realised that it was more to do with either one of 2 things:
          1. during boot stages eth0 and eth1 are conflicting
          2. network settings were applied to card before it was properly initialised

          anyways good luck

          P.s. sorry bout the poor description of what to do, i simply dnt have time at the moment (im at work)


          • #6
            just one other thing, maybe the orinoco card doesn't work well with iwconfig, try changing settings (like monitor mode) using the command "iwpriv"

            i think it could be something like

            # iwpriv eth1 monitor 1 2 (thats a wild guess tho)

            heres a itytle more on iwpriv....

            * # iwconfig : lists all wireless cards installed on the system with 802.11 configurations. My system shows me eth2 to be my orinoco card.
            * # cardctl info : gives information about the card in the PCMCIA slot.
            * # iwpriv eth2 : lists the possibilities of I/O of the orinoco card. There is no monitor entry shown (yet).


            • #7
              maybe this will help

              best of luck


              • #8
                Originally posted by FunkyChicken
                Sorry, I was offline for a while, relocating to another continent. This link you've posted comes up page not found. Can you tell me what it said?

                as for the iwconfig iwpriv thing, I don't think so as I have always used iwconfig with my orinoco cards, and continue to do so on other laptops. It's just something about this laptop that's causing a conflict.