Announcement

Collapse
No announcement yet.

Right, thats it! Ive had enough!!!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by FunkyChicken
    ive just used nslookup in windows.
    is this my dns ip address?
    Code:
    C:\Documents and Settings\Matt Phillips>nslookup
    Default Server:  Federal.Hardware
    Address:  192.168.1.1
    The above address (192.168.1.1) is the address that is being used by that instance of nslookup to perform the query you provided.

    Code:
    > www.google.com
    Server:  Federal.Hardware
    Address:  192.168.1.1
    You are again told what address is being used for this DNS lookup

    Code:
    Non-authoritative answer:
    Name:    www.google.akadns.net
    Addresses:  66.102.11.99, 66.102.11.104
    Aliases:  www.google.com
    these two addresses are passed to you (directly or through your router DNS relay/service) as being valid for "www.google.com" (both addresses should work as google websites.)

    Comment


    • #17
      Ive asked linux to use the KDE front, how do i set it to use the GNOME front as this looks a little nicer.

      Comment


      • #18
        Originally posted by FunkyChicken
        Ive asked linux to use the KDE front, how do i set it to use the GNOME front as this looks a little nicer.
        I don't know, since I do not use mandrake. However, google to the rescue.
        1 http://www.mandrakeclub.com/article.php?sid=844
        2 http://docs.kde.org/en/3.2/kdebase/k...-with-kdm.html

        HTH

        Comment


        • #19
          hi, im writing this in linux so i know that my internet works except for my dns

          How the hell do i fix this?

          i can access google when i type in the ip address but for some reason im unable to connect to google when i use www.google.com

          this is soooo annoying

          i have tried reseting my router to see if it was a problem with that, but nope, same problem.

          im sure its got something to do with the dns problems

          Comment


          • #20
            Originally posted by FunkyChicken
            hi, im writing this in linux so i know that my internet works except for my dns

            How the hell do i fix this?
            Did you try the suggestions above with the use of dig on the linux box? What were the results? Did you examine the contents of /etc/resolv.conf? what was in it?

            If dig does not work against your router, then perhaps it is a filter issue with ipchains/iptables. Please report the results from using dig from your linux box.

            Comment


            • #21
              I can fix the DNS problem by going to "Configure your Computer" then manually entering my dns server ips, (got them from status page in my router config)

              194.72.9.38
              194.74.65.68

              everytime i reboot the machine the get set to

              Primary: 127.0.0.1
              Secondary: 192.168.1.1

              here is the response i get from the dig command ( i done this after i change them to proper dns ips)

              Code:
              [matt@Federal matt]$ dig @192.168.1.1 www.google.com
              
              ; <<>> DiG 9.3.0 <<>> @192.168.1.1 www.google.com
              ;; global options:  printcmd
              ;; Got answer:
              ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46575
              ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0
              
              ;; QUESTION SECTION:
              ;www.google.com.                        IN      A
              
              ;; ANSWER SECTION:
              www.google.com.         734     IN      CNAME   www.google.akadns.net.
              www.google.akadns.net.  158     IN      A       216.239.59.99
              www.google.akadns.net.  158     IN      A       216.239.59.104
              
              ;; Query time: 37 msec
              ;; SERVER: 192.168.1.1#53(192.168.1.1)
              ;; WHEN: Wed Jan 19 18:21:36 2005
              ;; MSG SIZE  rcvd: 99
              My TCP/IP protocol is set up to be DHCP, does this mean that the dns server is getting set by my router each time i reboot??
              Last edited by FunkyChicken; January 19, 2005, 11:30.

              Comment


              • #22
                Originally posted by FunkyChicken
                I can fix the DNS problem by going to "Configure your Computer" then manually entering my dns server ips
                OK... Quick recommendation: avoid using nonstandard stuff like graphical configuration utilities. I know you're new to Linux, but you'll be better off in the long run knowing where the configuration files they change reside and how to edit them manually.

                Having said that, try editing /etc/resolv.conf manually in whatever editor shipped with your distro (I'm guessing that as a fallback, you've probably got at least xedit in there somewhere) to include your DNS server IP addresses. It's entirely possible that the graphical configuration utility you're using isn't committing the changes properly or due to some internal weirdness with it is overwriting resolv.conf every time you open it.

                Comment


                • #23
                  i just tried to edit it but it says i dont have write access?

                  where can i find xedit?

                  Comment


                  • #24
                    you guys think i should install fedora instead? is it easier to use then mandrake?

                    Comment


                    • #25
                      Originally posted by FunkyChicken
                      i just tried to edit it but it says i dont have write access?
                      You'll need to be logged in as root. su is your friend.

                      where can i find xedit?
                      `locate xedit' (note: if you get an error saying that there's no default database, su to root and do an `updatedb')

                      Also: recommended reading.

                      Originally posted by FunkyChicken
                      you guys think i should install fedora instead? is it easier to use then mandrake?
                      It's all Linux at its core. You're only going to have to learn a different distro's peculiarities if you move to another one.

                      Comment


                      • #26
                        Originally posted by FunkyChicken
                        i just tried to edit it but it says i dont have write access?
                        You need to have root permissions to change that file (look into the command `sudo` at some point).

                        I guess the problem is that the primary (first in /etc/resolve.conf) nameserver is 127.0.0.1 (localhost)? Please post the contents of /etc/resolve.conf after a system reboot so we can actually see what is going on.

                        Comment


                        • #27
                          Originally posted by FunkyChicken
                          I can fix the DNS problem by going to "Configure your Computer" then manually entering my dns server ips, (got them from status page in my router config)
                          Originally posted by skroo
                          avoid using nonstandard stuff like graphical configuration utilities.
                          I agree with that. There is a problem with this in the RedHat land (not sure about others.) If you decide to depart from the GUI system config tools, you should no go back to them while you manually edit config files, because there is risk that the nexttime the GUI config tools are run, for you to lose your custom settings.

                          Using a text-teditor is how I do things, and it helps me to understand the services and their configuration in greater detail. This is (IMO) the direction a hacker would likely take to familiarize themself with a system.

                          Originally posted by funkychicken
                          194.72.9.38
                          194.74.65.68

                          everytime i reboot the machine the get set to

                          Primary: 127.0.0.1
                          Secondary: 192.168.1.1
                          Yes. This is what I was writing about before. First, we see that since it works with these DNS IP addresses entered on the Linux box manually, we have a good indication that it is not a filtering problem. (This narrow the scope of our search.)

                          Next, every reboot, your dhcp client likely runs and modifies the contents of /etc/resolv.conf (this is also the file that is being modified when you use that GUI tool to manually enter in your DNS IP addresses.)
                          What to look at next:
                          1) Is the DHCP server on your NAT/DSL Router configured to offer addresses for your DNS as 194.72.9.38 and 194.74.65.68 or is it configured to not specify any DNS? Can you set your DSL Router/NAT box to send client the 194.72.9.38 and 194.74.65.68 IP addresses for DNS? If so, try this.

                          2) Your dhcp client may be configured to ignore dns offered from theserver too, and instead use something provided during install/config or a default.

                          Item 1 or 2 are the likely problems you want to tackle.

                          Originally posted by funkychicken
                          here is the response i get from the dig command ( i done this after i change them to proper dns ips)

                          [CHOP]
                          The code results show me that 192.168.1.1 is acting as a DNS for you and should be a valid entry on your local machine. However, 127.0.0.1 is probably not valid if you dont have a local DNS Service running in Linux or it is misconfigured/not working.

                          The other two DNS are probably your ISP's DNS.

                          Originally posted by funkychicken
                          My TCP/IP protocol is set up to be DHCP, does this mean that the dns server is getting set by my router each time i reboot??
                          Yes. Your /etc/resolv.conf is being overwritten with new DNS info every time your get a new DHCP lease/assignment.


                          Another solution:
                          Tell your NAT/DSL Router to allow for assigning a static IP address to your Linux box based on its MAC Address, or see if you can allocate static IP addresses for machine on your network and have that work with your NAT/DSL Router. Then, you can switch your Linux box from using DHCP for assigned address to using a static assignment of an IP address and DNS that will not change on every reboot.

                          Comment


                          • #28
                            contents of resolv.conf

                            Code:
                            nameserver 127.0.0.1
                            nameserver 192.168.1.1
                            i thought as i was the only user it means i am the administartor

                            Comment


                            • #29
                              Originally posted by FunkyChicken
                              contents of resolv.conf

                              Code:
                              nameserver 127.0.0.1
                              nameserver 192.168.1.1
                              Yes. This is the file where your DNS IP Addresses are stored.

                              [BAD ADVICE]
                              You could always edit this file as root, set the IP addresses of your DNS that work (manually enter them) save the file, and then use "chattr" to set the immutable flag on /etc/resolve.conf so that the file cant be edited or altered or deleted unless chattr is used to remove the immutable flag.
                              [/BAD ADVICE]


                              i thought as i was the only user it means i am the administartor
                              With most *NIX systems, it is best to be a normal user unless you have admin-things to do. When you have admin things to do, then you either "su" to root or you use "sudo" to complete a specific task.

                              Some *NIX distros (Like Lindows) make the default user "root" but that is a bad practice.

                              *NIX can be unforgiving. You may have cases where you are not asked, "Are you sure you want to do this?" , "Are you really sure you want to do this?" , "Can you rovide a note from your mommy that you really want to do this?" ... In many cases, *NIX systems are set up to just do what you tell them...no questions asked.

                              examples:
                              DO NOT DO THIS:
                              # cat /dev/zero > /dev/hda
                              (Zeros out your primary master IDE/ATA/EIDE hard disk)

                              DO NOT DO THIS:
                              # rm -rf /
                              (tries to delete all files on the system)

                              DO NOT DO THIS:
                              # kill -9 -0
                              (tries to kill all processes owned by root, though "-0" option may not be available on all kill apps.)

                              Comment


                              • #30
                                arggghhhh!!!!
                                Code:
                                [matt@Federal matt]$ sudo [-u matt]
                                matt is not in the sudoers file.  This incident will be reported.
                                [matt@Federal matt]$
                                ive just gone out and bout a book called linux for dummies, it comes with fedora so i was thinking if i installed this it would be easier to follow as the distro would be the same as in the book

                                Comment

                                Working...
                                X