Announcement

Collapse
No announcement yet.

PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

    Major forum maintenance. Forums may be unavailable for 1 to 3 hours.
    This will start at around 9:30pm Pacific time.

    Comment


    • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

      Between DT and me, a BUNCH of maintenance, upgrades, and more has been completed. Everything from OS, libs, apps, db, through to forum software and plugins.

      As a result, I expect one or more things are probably broken in the forums. If you notice something is not working as it should, or was, please let me know here.

      Thanks for your help!

      We have at least one more round of maintenance coming up over the next day or two, and it may also cause new problems to be introduced.

      -Cot

      Comment


      • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

        It seems that the forum displays the "red unlocked" HTTP icon, even when I am showing HTTPS in the URL.

        http://www.geocities.com/theprez98/ScreenShot001.tif

        However, when you refresh or otherwise change the page (i.e., search for new posts), it reverts back to HTTP.
        "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

        Comment


        • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

          Originally posted by theprez98 View Post
          It seems that the forum displays the "red unlocked" HTTP icon, even when I am showing HTTPS in the URL.

          http://www.geocities.com/theprez98/ScreenShot001.tif

          However, when you refresh or otherwise change the page (i.e., search for new posts), it reverts back to HTTP.
          Yup, I'm having the the same problem, on both Firefox 2.0.0.14 and IE 7.

          xor's seeing the same thing on Firefox 3:
          http://forum.defcon.org/showthread.php?t=9486
          Thorn
          "If you can't be a good example, then you'll just have to be a horrible warning." - Catherine Aird

          Comment


          • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

            Thanks for these reports! :-)

            I am able to duplicate them and I've found the cause, but this is a firewall control issue and not something that can be fixed on the forum box.

            This may add another brief period of down-time if he loads new rules. This will be in addition to a reboot of the forums box to apply some changes and verify that all of the new services start up as they should.

            If you noticed short period of unavailability over the last 90 minutes, where each period lasted 10 to 45 seconds, that was me converting the old, no longer supported URL replacement system with a new, more standard system. That is now live (again.)

            Issues reported last night with the NAV-bar projects and blog were also fixed last night.

            (If you notice that your https session is suddenly redirected into an http session (no ssl) this is likely attributable to the same problem with the "red no-ssl image" you see at the top. Once that works as it did, any https->http problem should be gone too.)

            What else is busted? The weekend is coming, and I need something to do. ;-)

            Originally posted by theprez98 View Post
            It seems that the forum displays the "red unlocked" HTTP icon, even when I am showing HTTPS in the URL.

            http://www.geocities.com/theprez98/ScreenShot001.tif

            However, when you refresh or otherwise change the page (i.e., search for new posts), it reverts back to HTTP.
            Originally posted by Thorn View Post
            Yup, I'm having the the same problem, on both Firefox 2.0.0.14 and IE 7.

            xor's seeing the same thing on Firefox 3:
            http://forum.defcon.org/showthread.php?t=9486

            Comment


            • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

              I broke Neil's fabulous updates to the forums with new images and the present default theme. Sorry about that Neil.

              I think it is fixed now.

              What else?

              Comment


              • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

                Crap. The software is lying to me (and all of you) !

                It seems the requests to 443 really are coming in on 443, but the web server and php have conspired to leave the env variable for service port to always be 80.

                I'll be rebuilding both this eve, and load the forums software into the new build. Either a module is not being loaded, or there is some mis-behaving code.

                Comment


                • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

                  Turns out this was a problem on my end, not the firewall. The web server was lying to me, and settings documented as working with this new release don't work as described.

                  Static assignment, and we are back in business for https session remaining https sessions.

                  This exposes a new problem. The rule in place to coerce http[s]://.*.defcon.org links to follow the same protocol (http or https) as the session the user is using is a little overzealous, and is disallowing users access to change from http to https by clicking that link at the top. I know this needs to be fixed, and it is on my plate. [Edit: and this is now fixed]

                  What else?
                  Last edited by TheCotMan; June 20, 2008, 18:56.

                  Comment


                  • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

                    My green lock is back. Thanks. ;)
                    "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

                    Comment


                    • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

                      Originally posted by theprez98 View Post
                      My green lock is back. Thanks. ;)
                      Happy to help. :-)


                      Maintenance on pics is mostly comeplete.

                      Please let me/us know if you see any problems on pics too.

                      pics will be down again later tonight (~8:00pm) for one more cycle of maintenance.

                      Comment


                      • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

                        Maintenance on pics is complete.

                        Please report problems with pics here.

                        I think i am done with my maintenance cycles for public forums.
                        testforums will get work over the weekend.
                        Last edited by TheCotMan; June 20, 2008, 22:30.

                        Comment


                        • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

                          Someone* contacted me to let me know that there may be maintenance on network equipment for the defcon.org network around 4:00pm today, and could last up to 3 hours, to diagnose a problem. Network access may be intermittent during this time.

                          *- I don't know if they want their name known, so it remains "someone" until I hear otherwise.

                          Thanks!
                          -Cot

                          Comment


                          • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

                            This maintenance has been postponed until tomorrow.

                            Originally posted by TheCotMan View Post
                            Someone* contacted me to let me know that there may be maintenance on network equipment for the defcon.org network around 4:00pm today, and could last up to 3 hours, to diagnose a problem. Network access may be intermittent during this time.

                            *- I don't know if they want their name known, so it remains "someone" until I hear otherwise.

                            Thanks!
                            -Cot

                            Comment


                            • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

                              l3d will be performing network maintenance which could last up to 3 hours, or more if something unexpected happens.

                              Sunday, June 29, 2008, 2:00pm-5:00pm Pacific time, the forums, pics, and main defcon web page may be subject to occasionally denied access while l3d performs some maintenance to networking equipment.

                              Thanks!
                              -Cot

                              Comment


                              • Re: PUBLIC-NOTICES: Forum Changes/Fixes. Any Questions?

                                The mail server that relays mail for the forums was unavailable for about 40 hours. It is working again. If you registered for an account, but never got the email confirmation, you should be able to log in and reset your email address to reset it. Same with password resets, as you should be able to request such an email again.

                                Comment

                                Working...
                                X